How To:How To Get Flash Working in Opera 9.27

The current version of Flash 9.0.115.0 does not work with the current version of Opera 9.27. but Opera9.27 does work with Flash 9.0.48.0. This is how to get that working without making trouble for firefox or later versions of Opera that are coming and will work with Flash 9.0.115.0


To get flash to work in Opera 9.27 which is the version available in the repository you must do the following:


First go here which is the adobe repository for older versions of flash and download flashplayer 9 to your desktop or wherever. Unpack it. The readme will direct you to the folder with the linux version which is 9r48. Unpack that.

You can use archive manager which is in Applications/ Accessories to do this part. If you can't see it there go to System/Preferences/Main Menu and check the box to make it visible.

This will then create a folder called install_flash_player_9_linux. Take the file in there called libflashplayer.so and move it to /usr/lib/opera/plugins.

Now just type sudo nautlius in a terminal and use two nautilus windows to go to the right locations and did a drag and drop.

Important Note:- Do not use nautlius like this unless you are absolutely sure about what you are doing and be sure to close it right away when you are finished. It is easily possible to put your system in an unrecoverable state by moving random files around as root.

Then navigate over to /usr/share/opera/ini and open the pluginpath.ini file. Scroll down to the section that says ; Flash and comment out the lines:

/usr/lib/flash-plugin=1
/usr/lib/flashplugin-nonfree=1

and add the line:

/usr/lib/opera/plugins=1

so it looks like this:

; Flash
#/usr/lib/flash-plugin=1
#/usr/lib/flashplugin-nonfree=1
/usr/lib/opera/plugins=1

Save it and get out of there.

Now flash should work in your opera and enjoy

When you get Opera 9.5 you can just remove the comment marks and the line you added in /usr/share/opera/ini/pluginpath.ini and just put the old flash in the trash.